I can’t see posts from my instance, how does federation work with lemmy?

@axeltherabbit
admin
creator
link
fedilink
26M

Thank you, now I added lemmy.ml in the allowlist config but I can only see some posts from foreigns communities, does it only take some time to sync or I’m doing something wrong?

@nutomic@lemmy.ml
mod
link
fedilink
26M

You need to fetch remote objects (communities, posts etc) by entering the url in search.

@axeltherabbit
admin
creator
link
fedilink
26M

what do you mean? for every single remote post I have to manually search it? don’t I get a simple feed?

@nutomic@lemmy.ml
mod
link
fedilink
36M

You can follow communities, then you get new actions automatically delivered.

@axeltherabbit
admin
creator
link
fedilink
26M

Oh i see, so there is no way to get old posts right?

@nutomic@lemmy.ml
mod
link
fedilink
16M

There is, you need to enter the post url in your instance search so it gets fetched. Similar for comments (make sure to use the url from the colored fediverse icon, not the normal comment url).

@axeltherabbit
admin
creator
link
fedilink
16M

but I have to get them one by one right?

@nutomic@lemmy.ml
mod
link
fedilink
16M

Yes, or write a script to automate it.

@axeltherabbit
admin
creator
link
fedilink
16M

I see, it could be a partial solution but it would be nice to have an automatic fetch via API of the last 10 or more posts when a community is loaded for the first time or when the user looks for older posts

@nutomic@lemmy.ml
mod
link
fedilink
1
edit-2
6M

It actually does fetch the last posts in that case. But no votes, comments etc. Of course that could be implemented in the future.

@axeltherabbit
admin
creator
link
fedilink
16M

mh, it doesn’t seem to work then :0, maybe it fetches by time and not by last posts? so for instance if I look for a community without recent posts I get nothing?

@nutomic@lemmy.ml
mod
link
fedilink
16M

It should work regardless, but maybe there is a bug.

@axeltherabbit
admin
creator
link
fedilink
26M

I think so or I have some issues in my config, when I loaded lemmy.ml/c/piracy and lemmy.ml/c/meta from here for the first time they were empty

@nutomic@lemmy.ml
mod
link
fedilink
1
edit-2
6M

Okay i just tried with this search and it fetched latest posts just fine. Do you see any errors in the server logs when fetching a new community? Use docker-compose logs -f --tail=100 lemmy

@axeltherabbit
admin
creator
link
fedilink
26M

I don’t really get it, for the communities I tried now and it kinda works, it sometime takes time and I have to refresh the page but https://lemmy.wiredentrypoint.xyz/c/peertube@lemmy.ml is still empty, even https://lemmy.wiredentrypoint.xyz/c/meta@lemmy.ml didn’t load much https://pastebin.com/Yc11mS79 here some logs with a “grep peertube”, no errors in the latest logs

@nutomic@lemmy.ml
mod
link
fedilink
16M

I looked into this today and noticed two problems. First, fetching a community is very slow because each post gets processed one by one. Also, the search loading indicator is broken. This means you have to keep waiting even if nothing seems to happen, and it can take more than 3 minutes in the worst case.

parallel fetching fix

loading indicator fix

As for the peertube community, it fails to serve the outbox for some reason, so posts cant be fetched.

@axeltherabbit
admin
creator
link
fedilink
26M

Thank you :)

@Echedenyan@lemmy.ml
link
fedilink
1
edit-2
6M

This sounds something to be made through a Federation Bot.

@axeltherabbit
admin
creator
link
fedilink
1
edit-2
6M

deleted by creator

Anything about the lemmy.ml instance and its moderation.

For discussion about the Lemmy software project, go to !lemmy@lemmy.ml.

  • 0 users online
  • 1 user / day
  • 1 user / week
  • 15 users / month
  • 28 users / 6 months
  • 1 subscriber
  • 24 Posts
  • 90 Comments
  • Modlog